1
$\begingroup$

Disclaimer

The issue seems to be due to restricting the function on an interval, even though the solution is within the given range. It seems to be a bug in Geogebra, and I have submitted a ticket for the developers.

Leaving this question un-deleted as documentation.


Background

I have a function $f(x)$ defined by the FitExp command, restricted by $0 \leq x \leq 50$.

I want to solve $f(x) = 100$, and I've tried both the Solve and NSolve commands, but they both yield $?$ as the answer. See image below.

Question

Is there another command I should be using for this, or is there some other input needed before this will give the answer?

NOTE

All commands in CAS were entered after all the commands in the Algebra view. Meaning, $f(x)$ was defined before I tried to use Solve and NSolve.

enter image description here

$\endgroup$
1
$\begingroup$

Im using the desktop version of geogebra. Defining your function in the algebraic view

$$f(x):=6.17 e^{0.1 x}$$

by typing in the bar

f(x)=6.17 e^(0,1 x)

and after using the command in the CAS view

Solve[f(x)=100,x]

I get the answer

$$\left\{x=10\ln\left(\frac{10000}{617}\right)\right\}$$

Indeed it also works with the command

Solve[f(x)=100]

Probably it doesnt work for you because you had restricted $f$ in $[0,50]$ (I dont know how to do this, but I can see it in your picture).

$\endgroup$
  • $\begingroup$ Strange. I started a new window, and doing it all the same, now it works. I've created an issue for the Geogebra developers. Could be some strange caching issue from a previous session. $\endgroup$ – Alec May 17 '17 at 16:02
  • 1
    $\begingroup$ @Alec probably it is because you had $f$ defined only for $x\in[0,50]$, at least it seems so in your picture. How you had restricted $f$ in this domain? $\endgroup$ – Masacroso May 17 '17 at 16:03
  • 1
    $\begingroup$ f(x) = Function[FitExp[list1], 0, 50] followed by Solve[f(x)=100] does indeed seem to fail, while leaving out the restriction makes everything work. $\endgroup$ – Alec May 17 '17 at 16:07
  • 1
    $\begingroup$ @Alec indeed this is a bug. Well, if you had sent a ticket probably it will disappear in the next version of geogebra :) $\endgroup$ – Masacroso May 17 '17 at 16:10
  • 1
    $\begingroup$ Good observation. I have updated my ticket for the developers. Thanks for your help! $\endgroup$ – Alec May 17 '17 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.