6
$\begingroup$

I was looking for a fast way of getting which function is surjective and injective. So I tried to find such command in wolfram and surprisingly it says to me that $ln(x)$ is not injective. Link to proof: http://www.wolframalpha.com/input/?i=ln%28x%29+is+injective%3F

The questions are:

(1) Why did Wolfram|Alpha say that it is not injective?

(2) How the injectivity is defined in Wolfram?

$\endgroup$
  • $\begingroup$ This is really weird (I would have expected this to be a problem with the domain, but WA has chosen precisely the domain it ought to in order to get an injective function). $\endgroup$ – Tobias Kildetoft Oct 2 '15 at 11:06
  • $\begingroup$ I was expecting something like this too, but as we can see, Wolfram gets the domain rightly. That's why I asked it here. $\endgroup$ – Mesmerized student Oct 2 '15 at 11:07
  • $\begingroup$ I've reported it to them. Looks like a bug. Mathematica sheds no light on it either. $\endgroup$ – Patrick Stevens Oct 2 '15 at 11:12
  • 2
    $\begingroup$ Looks like a bug, note: wolframalpha.com/input/… $\endgroup$ – martini Oct 2 '15 at 11:18
  • $\begingroup$ It's still not fixed! $\endgroup$ – Andrea Aug 30 '16 at 23:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.