Take the 2-minute tour ×
Mathematics Stack Exchange is a question and answer site for people studying math at any level and professionals in related fields. It's 100% free, no registration required.

When writing software, there are often situations where I need a parameter to be a floating point number $x \in [0,1]$. I don't know of a name for that category, but I think there must be one because it's such a useful categories. Perhaps there's a name in probability theory?

(If they don't have a name, I hereby declare them to be "wombat numbers".)

share|improve this question
2  
It's just the closed interval [0,1] –  Charles Siegel Aug 14 '10 at 23:35
4  
(tongue-in-cheek) Since there's no such thing as "irrational" or "transcendental" in floating-point... maybe "proper fractions"? –  J. M. Aug 15 '10 at 0:23
2  
Just a curiosity: In Romanian they are sometimes called subunitary numbers (although it sometimes means in [-1,1]). Apparently in English "subunitary" is reserved for matrices. –  rgrig Aug 15 '10 at 5:51
1  
Not sure I've seen "subunitary" in use, but "unitary" is indeed an adjective frequently used in the theory of matrices. –  J. M. Aug 15 '10 at 12:31
1  
I'm running into the same question wrt probability numbers. Since all of the "official" answers seem to be multiword ("property fraction", "unit interval"), I'm going to go ahead and accept your declaration of "wombat" numbers, with my code reading getFloat(), getInt(), getWombat(). –  James Beninger Sep 22 '13 at 2:35

1 Answer 1

up vote 14 down vote accepted

Sometimes I've heard it called the "unit interval" as it "probability measures are functions from a boolean algebra to the unit interval"

share|improve this answer
    
I'd imagine the 'unit interval' refers to the set [0,1], but you wouldn't say that the number 0.3 is a "unit interval number" in the same way that you might say that 2/3 is a "rational number". It's not entirely clear from the question but I think it's asking for a term to describe any number in the set, not to describe the set itself. –  bryn Aug 15 '10 at 2:08
4  
"Numbers in the unit interval" works. –  Michael Lugo Aug 15 '10 at 5:28
2  
Thank you very much. Now I don't have to name my function "parseNumberBetweenZeroAndOne". –  Amy de Buitléir Aug 15 '10 at 20:43
4  
You should still call your function parseWombatNumbers. Semantic function names are for wimps. All my functions are called "foo78" "bar429" and so on –  Seamus Aug 16 '10 at 9:26
    
@Seamus To the contrary, naming things is one of the hard problems. Only wimps give up on meaningful names. ;) –  jpmc26 Feb 14 at 6:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.