Take the 2-minute tour ×
Mathematics Stack Exchange is a question and answer site for people studying math at any level and professionals in related fields. It's 100% free, no registration required.

This may have a proper name, if so - let's discuss. If not, let's name it. This is for a web application in C#, so whatever we call it I will start naming as such in my code.

I'm taking GPS data as a collection of n 'Points', each point has latitude (degrees), longitude (degrees), elevation (meters), and datetime(DateTime object). From this, I compute a list of n-1 'Segments.' In each Segment object, I have distance(meters), time(seconds), and velocity(meters/second), effectively taking the derivative between each consecutive point.

Now, I want to n-2 "name this object"s. Each will have acceleration (meters/second/second). A good name for a collection of segments may be 'Path' or 'Track', but this is specifically an object that is two segments only (comprised from three consecutive points), which holds the second derivative value.

I'm leaning toward 'Segue' and this will be the object's name as I flesh out the details. Is there an existing name for this concept, or does anyone have any suggestions?

share|improve this question
1  
Feel free to make up a new term, too - especially if this concept hasn't been clearly defined. There may be no correct answer here - get creative! –  Ehryk Mar 27 '12 at 15:08
    
This may be off topic, but I won't rely on acceleration values estimated from only 3 points - given that the spatial accuracy is typically at most 2 meters. –  Hagen von Eitzen Sep 16 '12 at 20:52

3 Answers 3

This is just a "second order finite difference approximation" to the path. Feel free to give it a contextual name (it does not have one, per se), but people won't necessarily know what you're talking about.

However, if you talk about taking a second order finite difference approximation to a time-series of position data, I know exactly what you're talking about right away.

share|improve this answer
    
Cool - thanks for that. Can you suggest some good 1/2 word names for this? There's no wrong answer (of course) - just help me call it something that invokes this concept or is better to write in code than secondOrderFiniteDifferenceApproximation! –  Ehryk Sep 14 '12 at 16:58
    
double[] finiteDiff2; // Second order finite difference approximation :) –  Arkamis Sep 14 '12 at 17:02

What about "InterpolationTriple"?

share|improve this answer

How about point, segment, arc?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.